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Chapter 2 
I. Organizing Data in Tables 

II. Describing Data by Graphs 

I. Tables: 

1. Frequency Distribution (Nominal or Ordinal) 

2. Grouped Frequency Distribution  (Interval or Ratio data) 

3. Joint Frequency Distribution for Two Variables (Qualitative or Quantitative)  

 

The Excel functions, Excel Analysis ToolPak Add-ins or Excel PHStat2 Add-ins needed to create frequency 

distributions are: 

 

1. Frequency Distribution (Nominal or Ordinal) 

A. FREQUENCY: To construct a Frequency Distribution for numeric discrete values such as the 

number of magazines sold, number of absent students, number of children in a family, or numeric 

code such as (1=Male, 2=Female) 

a. List the possible values of the variable under study (the bins). 
b. Select the cells to contain the frequency values.  

c. Click Formulas  Tab Functions Statistical FREQUENCY 

d. Select the Data array  

e. Select the Bins array 

f. Press (Control +Shift ) + Enter   

Note: You have to hold the (Control +Shift) then press ENTER 

              

                

 Example:  Construct a frequency distribution for the variable gender, for the data in the 

 fileCapital.xls. 
 Open file:  Capital.xls 

a. Enter the possible values for gender 1 and 2 in cell E4:E5 
b. Select the cells to contain the frequency F4:F5 
c. Select the data array cells C2:C301                          
d. Select the bins array cells E4:E5  
e. Press (Control + Shift) +Enter.   
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 The result s will be displayed in cells F4:F5 
 

                                      

                                
B. COUNIF: To construct a Frequency Distribution for numeric or non-numeric values such as the 

blood type, major, drink preference, marital status, color preference. 

a. List the possible values of the variable (the bins). 
b. Select the cell to contain the frequency.  

c. Click Formulas Tab Functions Statistical COUNTIF 

d. Select the input range 

e. Select the criteria (Number, text, a condition) 

 

                     

Example:  Construct a frequency table for the blood type, for the data in the file Blood.type.xls 
Open file:  Blood.type.xls 

a. Enter the possible values for blood type A, AB, B and O in cell C4:E7 
b. Select the cells to contain the frequency D4:D7 

c. Select the data array cells Range A2:A51                        
d. Criteria “A” and repeat the same steps for the blood type AB, B, and O 

e. Or type the cell reference    which contains the letter “A”, then use the filler for the other blood 

types. ( you need to change the Range A2:A51 that you selected to A$2:A$51) 
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   The result s will be displayed in cells D4:F7      
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2. Grouped Frequency Distribution (Interval or Ratio data) 

      Determine the number of classes using the 
k n2  guideline rule. 

      Find the Maximum and Minimum Values 

      Find the class width
Max Min

w .
K

 
  

84 18
9 4 10

7
; it should contain the number of decimal   

      values as the data.  

      Use the lower limit a nice number such as 5, 10 or 20, must be less than or equal the minimum value.   

      Use upper class limits (Excel bins) for discrete classes. 

 

      Example:  Given a set of data with n=100, min=18, max=84 

           
log n log

k .
log log

  
100

6 64 7
2 2

 

          
Max Min

w .
K

 
  

84 18
9 4 10

7
 

      Classes can be constructed by choosing the lower limit =minimum=18 as in Table-1or the lower limit =15  

      as in Table-2 or lower limit=10 as in Table-3 

 

Table -1 

 

Table - 2 

 

Table - 3 

 

Table - 4 (continuous classes) 

         
Classes 

 

Classes 

 

Classes 

 

Classes  

  18-27 

 

15-24 

 

10-19 

 

10 --< 20 

  28-37 

 

25-34 

 

20-29 

 

 20 --< 30 

  38-47 

 

35-44 

 

30-39 

 

30 --< 40 

  48-57 

 

45-54 

 

40-49 

 

40 --< 50 

  58-67 

 

55-64 

 

50-59 

 

50 --< 60 

  68-77 

 

65-74 

 

60-59 

 

60 --< 70 

  78-87 

 

75-84 

 

70-59 

 

70 --< 80 

    

 

  

 

80-89 

 

     80 --< 90 

   

You can see that Table-3 is easier than table-1 even if it has one more class, because multiples of 10=class 

width is used for lower limits.   

 

Grouped frequency distributions can be constructed in Excel by: 

A. Data Data Analysis Histogram (with or without chart) 

B. Formulas FunctionsFREQUENCY 

C. Formulas Functions COUNTIF 

 

Example:  Use the data in the file Age.xls to construct a grouped frequency distribution using the classes in 

Table-3 above. 

 

A. Histogram  
a. Input the classes in column C3:C10 

b. Input the “Bins =Upper class limits” in column D3:D10 

c. Click Data Tab  Data Analysis  Histogram  OK 
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d. Input data cell A1:A101 Bins Range Cell D2:D10  Click Label box  for Output Range 

click cell E2 Ok 

 

                 
 

e. The output will be in cell E2:E11, Excel will give a “more” count of zero if the classes are 

inclusive. 
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B. FREQUENCY 
a. Input the classes in column C3:C10 
b. Input the Bins =Upper class limit in column D3:D10 
c. Select the cells to contain the frequency values E3:E10 

 

 
 

d. Click Formulas  Tab>Functions Statistical FREQUENCY 

e. Select the Data array A2:A101 

f. Select the Bins array D3:D10 

              

g. Press (Control +Shift ) + Enter   

Note: You have to hold the (Control +Shift) then press ENTER 
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h. The frequency will be in cell E3:E10 

       
 

Note 1:  The advantage of the frequency function is that when the raw data 

changes the result will be updated automatically, while the histogram command if 

the raw data changes the result will not change, you have to repeat the steps every 

time the raw data changes.   

The advantage of the histogram command is that it gives an extra class “more” 

which will include the count of any values which were not included by the last 

class; (if classes are not inclusive). 

Also histogram command you can have the graph of the data as a “Histogram” by 

choosing the chart output which will be explained later. 

 

Note 2: The bins for continuous classes are upper limit minus a small number 

based on the number of decimal places of the classes. 

For example Bins=Upper limit-0.1 as in Table -1 

Bins=Upper limit - 0.01 as in Table-2 

Bins=Upper limit - 0.001 as in Table-3 
 

              Table -1             Table -2           Table -3 
 

 

 

 

 

Classes Bins 

10-- < 20 19.9 

20-- < 30 29.9 

30-- < 40 39.9 

Classes Bins 

1.50 -- < 1.54 1.539 

1.54 -- < 1.58 1.579 

1.58 -- < 1.62 1.619 

Classes Bins                 

1.5-- < 2.0 1.99 

2.0-- < 2.5 2.49 

2.5-- < 3.0 2.99 
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C. COUNTIF (Optional) 

a. Input the classes in column C3:C10 
b. Input the Upper class limit s 19, 29,…..89  in column D3:D10 
c. Input the Lower class limit s 10, 20,…80 in column E3:E10 

 

 
 

d. Type  in cell F3 the formula =COUNTIF (A2:A101,”<=19”) – COUNTIF (A2:A101,”<10”) 
The result frequency count will be in cell F3  
Continue typing the formulas in cells F4… F10 
The formula in F10 will be =COUNTIF (A2:A101,”<=89”) – COUNTIF (A2:A101,”<90”) 
The result as shown below 
 

               
Note: For continuous classes replace “<=” by “<” in the COUNTIF formula   

          =COUNTIF (A2:A101,”<20”) – COUNTIF (A2:A101,”<10”) 
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3. Joint Frequency Distribution for Two Variables (Qualitative or Quantitative)  

A. Pivot Table:  To construct a Joint Frequency Distribution for two variables. 

a. Click Insert Pivot Pivot Table Select the variables or all the table 

b. Choose existing sheet  and specify the location or choose a new work sheet 

c. Move the variables for the column and rows 

d. Move value to the value field 

e. Right click and summarize data by count 

f. Format the table as needed 

Example 1: To construct a joint frequency table for two variables in the file Blood Type: 

a. Click Insert  Pivot Table Select the variables Blood type and Gender 

b. Choose existing sheet  and specify the location or choose a new work sheet click OK 

                  
c. Move the variable Blood type to Drop Row Field Here  

                
 

d. Move the variable Gender to Drop Column Fields Here 
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e. Move the variable Gender to Drop Value Fields Here 

 

                       

f. Place the cursor anywhere in the table Right Click Summarize data by Count 

      

Joint Frequency Table of Blood Type by Gender 

    Count of Gender Gender     

Blood Type F M Grand Total 

A 9 6 15 

AB 1 5 6 

B 4 6 10 

O 6 13 19 

Grand Total 20 30 50 
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II. Describing Data by Graphs 

1. Bar Chart (Vertical or Horizontal)  

2. Pie Chart 

3. Cluster  or Stack Bar Chart 

4. Histogram  

5. Ogive 

6. Stem and Leaf 

7. Line Chart 

8. Scatter Diagram 

 

1.  Bar Chart (Vertical or Horizontal): The following steps describe how to use Excel’s Chart Wizard to   

construct a bar graph for the blood type data using the frequency distribution appearing in cells E2:E5 

a. Select cells E2:E5 

b. Click the Chart Wizard button on the Standard toolbar (or select the Insert menu and choose 

the Chart option) 

c. Choose Column in the Chart type list 

 

              

d. Select the Layout TabGridlines  Horizontal > none 

e. Select the Titles tab  Chart Title  Choose Above Chart  (where you want the title) 

 Type “Bar Chart of Blood Type” in the Chart Title Box 

f. Select the Titles Tab Axis Title Horizontal  Choose below  axis 

 Type “Blood Type” in the Category (X) axis box 

g. Select the Titles Tab Axis Title Vertical  Choose rotated or (anything you prefer) 

 Type “Frequency” in the Value (Y) axis box 

h. Select the Legend Tab and then Remove the check in the Show legend box 

i. Click the Design Tab Move chart to the location you want or use the default sheet. 
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 The resulting bar graph (chart) 

                

Note: Relative frequency and percentage bar charts can be constructed using the same steps.  The only 

changes are in the cells selected. Select F2:F5 for relative frequency and G2:G5 for percentage.  The chart 

title and y-axis title will change accordingly. 
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2.  Pie Chart: The following steps describe how to use Excel’s Chart Wizard to construct a Pie chart for 

the blood type data in the file Boodtype.xls using the frequency distribution appearing in cells E2:E5 

a. Select cells E2:E5  

b. Click the Chart Wizard button on the Standard toolbar (or select the Insert menu and choose the 

Chart option) 

c.  Choose pie in the Chart type list 

d. Select the Titles tab  Chart Title Choose Above (where you want the title) 

Type “Pie Chart of Blood Type” in the Chart title box 

e. Select the Legend tab and then Remove the check in the Show legend box 

f. Click the design tab Move chart to the location you want or use the default sheet. 

 

The resulting Pie graphs (charts)  
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3. Cluster Bar and Stack Bar:  A bar graph is used to represent discrete values for more than one item 

that share the same category.  It can be side by side (cluster) or the bar divided into subparts that 

represent the discrete value for items that represent a portion of a whole group.  They can be 

constructed the same way as a bar chart.  

a. Select cells that contain the variables. 

b. Click the Chart Wizard button on the Standard toolbar (or select the Insert menu and choose the 

Chart option) 

c. Choose Column (Cluster) or Stack in the Chart type list 

d. Select the Layout TabGridlines Horizontal  None 

e. Select the Titles tab  Chart Title Choose Above  Chart (where you want the title) 

     Type “Cluster Bar Chart of Blood Type by Gender” in the Chart Title Box 

f. Select the Titles Tab Axis Title Horizontal  Choose below  

     Type “Blood Type” in the Category (X) axis box 

g. Select the Titles Tab Axis Title Vertical  Choose rotated or (anything you prefer) 

     Type “Frequency” in the Value (Y) axis box 

h. Select the Legend Tab and then Remove the check in the Show legend box 

i. Click the Design TabMove chart to the location you want or use the default sheet. 
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4. Histogram:  The following steps describe how to use Excel to construct a Histogram for quantitative 

data. 

 A histogram is a bar graph with no gaps between the bars.  The x-axis represents the classes. 

A.  Histogram from Grouped Frequency Distribution. 

B.  Histogram from Raw Data. 

 

A.   Histogram from Grouped Frequency Distribution as in the file Table-1 

a. Select the cells that represent the frequency and construct a bar chart. 

 

           
 

b. Click on any one of the bars>right click Format data seriesMove the gap to No Gap 

 

            
 

c. You can choose border color to show the border between the bars in a different color. 

d. The x-axis should have the classes 

Select the labels on x-axis then right click Select DataEditOK  
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Select the classes Ok  

 
 

 
 

                
 
B.  Histogram from Raw Data (File Age.xlsx) 

a. Type in the classes in cell C3:C8, the bins as the upper limits of the classes in cell D3:D8 

b. Click Data  Tab  Data Analysis  Histogram 

c. Input RangeBins Range Click label Output range 

d. Click Chart Output   Ok 
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e. The result will be a frequency table and a bar chart 

 

             

f. Remove the gaps and format the chart as discussed before. 
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5. Ogive:  A line chart of Cumulative Relative Frequency versus the upper limit of classes. 

   Example:  Develop an ogive for the data in the file “Age”. 

a. Select cells E3:E11 

b. Click the Chart Wizard button on the Standard toolbar (or select the Insert menu and choose the 

Chart option) 

c. Choose line with marks in the Chart type list 

d. Select the Layout Tab Gridlines  Horizontal  None 

e. Select the Titles Tab  Chart Title Choose Above (where you want the title) 

     Type “Ogive of Ages” in the Chart Title Box 

f. Select the Titles Tab Axis Title Horizontal  Choose below Chart 

     Type “Years” in the Category (X) axis box 

g. Select the Titles Tab Axis Title Vertical  Choose rotated or (anything you prefer) 

     Type “CRF” in the Value (Y) axis box 

h. Select the Legend Tab and then Remove the check in the Show legend box 

          Click the Design Tab Move chart to the location you want or use the default sheet. 
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Note: Ogive can be developed along with the histogram from raw data by checking the box as shown below. 

You need add a class at the beginning with frequency =0 because the ogive must be connected to the x-axis. 
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You can delete the bars by clicking on a one, right click, delete. 

Add chart title and axis title for the ogive.  The vertical axis is Cumulative Relative Percentage. 
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6.  Stem and Leaf (The data of exercise 2-37) 

a. Open PHStat2  Enable Macros  Add-In >PHStat2 

b. Descriptive Statistics  Stem & Leaf 

c. Input Range –Select the data with the label  

d. Click label in the first column 

e. The stem unit =10 

f. Then uncheck the summary statistic box, the OK 

       

                    

Stem and leaf constructed using Excel Add-in PHStat2 for the data of exercise 2-37: 

 

  Stem unit: 10 

  6  8 

7  1 3 4 6 9 

8  3 5 8 

9  0 2 3 

10  3 5 

11  0 6 9 

12 

 13  0 4 8 

14  5 6 7 

15  6 6 

16  2 

17  8 

18  1 
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7.  Line Chart:  A two dimensional chart showing the time on the horizontal axis and the variable of 

interest on the vertical axis. 

 Example:  Develop a line chart for the data in the file Line-Chart.xls 

a. Select cells B3:B8 

b. Click the Chart Wizard button on the Standard toolbar (or select the Insert menu and choose 

the Chart option) 

c. Choose line with marks in the Chart type list 

d. Select the Layout Tab Gridlines  Horizontal  None 

e. Select the Titles Tab  Chart Title  Choose Above (where you want the title 

Type “Passengers over the Years 2001-2006” in the Chart Title Box 

f. Select the Titles Tab Axis Title> Horizontal  Choose below Chart 

Type “Years” in the Category (X) axis box 

g. Select the Titles Tab >Axis Title Vertical  Choose rotated or (anything you prefer) 

 Type “Number of Passenger” in the Value (Y) axis box 

h. Select the Legend Tab and then Remove the check in the Show legend box 

i. Click the Design Tab Move chart to the location you want or use the default sheet. 

 

                   
 

8.  Scatter Diagram:   A two dimensional graph of plotted points.  The horizontal axis represents the 

values of one quantitative variable (Independent variable) and the vertical axis represents the values of 

the other quantitative variable (Dependent variable) 

 Example:  Develop a scatter plot of the data in the file Scatter-plot.xls 

a. Select cells C4:C13, D4:D14 

b. Click the Chart Wizard button on the Standard toolbar (or select the Insert menu and choose 

the Chart option) 

c. Choose scatter  

d. Select the Layout Tab Gridlines  Horizontal None 

e. Select the Titles Tab  Chart Title  Choose Above (where you want the title) 

          Type “Sales versus Advertising” in the Chart Title Box 

f. Select the Titles Tab Axis TitleHorizontal  Choose below chart 

           Type “Adds” in the Category (X) axis box 

g. Select the Titles Tab >Axis Title Vertical  Choose rotated or (anything you prefer) 

           Type “Sales” in the Value (Y) axis box 

h. Select the Legend Tab and then Remove the check in the Show legend box 

i. Click the Design Tab Move chart to the location you want or use the default sheet. 
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The chart shows a positive relation between the sales and advertising 
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